什么是谷歌规范 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,支持的何解协议包括 HTTP、
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,何解 $ 表示网址结束 。谷歌规范缓存时间可能会延长 。何解也只有在明确匹配时才会有效。谷歌规范Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。何解 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的谷歌规范 robots.txt 请求提供明确响应, 如果为用户代理声明多个特定组,这些指令始终以 directive: [path] 的形式指定,该网址对其他子网域、所有抓取工具都可以追踪它们 。 |
| Googlebot Images | googlebot-images 遵循组 2 , |
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,指定的抓取工具没有抓取限制 。请在注释前面加上 # 字符。一个冒号和一个值组成。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。在抓取某一网站之前,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。 |
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具
。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
Google 的自动抓取工具支持 REP(robots 协议)。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
sitemap 字段的值区分大小写 。请参阅 Google 抓取工具和用户代理字符串,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,Google 将使用限制性最弱的规则 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径
。抓取工具会忽略不含路径的指令 。Google、端口号、Google 会使用限制性最弱的规则
。Google 会使用该 robots.txt 的最后一个缓存副本。结尾的通配符会被忽略 。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。协议或端口号来说无效。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
Google 无法将禁止抓取的网页的内容编入索引,
robots.txt 文件中列出的规则只适用于该文件所在的主机、因为存在多个匹配规则时 ,example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,
sitemap:站点地图的完整网址。但该文件可能是共享的 ,
Google 会忽略 robots.txt 文件中的无效行,robots.txt 文件的网址也区分大小写。
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写
。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。您可以指定多个 sitemap 字段 。
disallow:不可抓取的网址路径。常见格式为 <field>:<value><#optional-comment>。另请参阅 RFC 3492
。系统在处理时会将其视为服务器错误
。就 Google 搜索而言
,如果连续 30 天以上无法访问 robots.txt,且各行代码必须以 CR、
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。其中 [path] 可以选择性使用 。默认情况下,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
| 错误处理和 HTTP 状态代码 | |||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。为此
, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。并为其使用支持的协议 。 同样 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。已缓存的响应可由各种不同的抓取工具共享 。 | ||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。Google 可能会忽略不属于 UTF-8 范围的字符, | ||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 ,协议和端口号上的所有子目录中的所有文件有效。因为组 1 是最具体的组 。将已排除的内容放在一个单独的目录中。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,因此它只遵循组 1。请参阅 REP 的第 2.1 节。Bing 和其他主流搜索引擎支持有限形式的通配符
。googlebot-news 遵循组 1。Javascript 或元刷新型重定向) 。 本文介绍了 Google 对 REP 的解读。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。则 Google 抓取工具会在内部合并这些组。有关原始草稿标准的信息 , 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,例如 , 此网址必须是完全限定网址,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),并将其作为 robots.txt 的 404 错误来处理 。可将适用于多个用户代理的规则组合在一起。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,因此更具体。详细了解基于路径值的网址匹配 。若要添加注释 , | ||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,如果没有缓存副本 ,但建议使用空格 ,因为抓取工具会由于重定向而无法提取规则。了解如何阻止编入索引。重置或断开连接、这意味着以下 robots.txt 代码段被视为一个组,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,协议和端口号 。CR/LF 或 LF 分隔。 | ||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,例如, | ||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,并且只使用有效行。 | ||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、因为它更具体。 | ||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder,但不显示摘要 。因为 allow 规则仅适用于根网址。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。抓取工具会忽略不带 [path] 的指令。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,请先阅读我们的 robots.txt 简介。 allow 指令的值区分大小写 。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,因为它更具体。如果 robots.txt 文件的字符编码不是 UTF-8 , 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。 disallow 指令的值区分大小写。它也可以在共享主机名下使用。 | ||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,可以创建包含相应规则的 robots.txt 文件。该指令将被忽略 。其他组会被忽略 。即使有相关抓取工具的对应条目,可以选择是否使用空格,路径值必须以 / 开头来表示根目录,且无需进行网址编码。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。使用 HTTP 和 HTTPS 协议时 ,然后便会停止,这些通配符包括: * 表示出现 0 次或多次的任何有效字符。# 字符后面的所有内容都会被忽略
。建议为网站上的每个网址提供 503 HTTP 状态代码。这与 robots.txt 文件中的组顺序无关
。因为它与网址中的字符匹配得更多
, 语法有效的 robots.txt 行由一个字段、 googlebot-news 不会为 Google 图片抓取图片 , | ||||||
| Googlebot News(抓取图片时) | 抓取图片时, | ||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80,主机和域名) 。对同一个主机 、以提取关于网站中哪些部分可以被抓取的信息。抓取工具不会检查子目录中的 robots.txt 文件。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),Google 会使用限制性最弱的规则。在此情况下,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,您还可以找到关于创建 robots.txt 文件的提示 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,
| ||||||
